Hour meter not working on Tiger Cub

zachem

Forum Newbie
Joined
Jun 10, 2020
Threads
1
Messages
3
Hello all, I purchased a ~04-05 Scag Tiger Cub second hand. Ive noticed the hour meter is not working on it. It displays a set hour, but does not go up after use. Is there a way to reset it, get it to start working again so I can monitor the hourly use? Thanks.
 

4getgto

Well-Known Member
Joined
Feb 4, 2017
Threads
1
Messages
179
Hello all, I purchased a ~04-05 Scag Tiger Cub second hand. Ive noticed the hour meter is not working on it. It displays a set hour, but does not go up after use. Is there a way to reset it, get it to start working again so I can monitor the hourly use? Thanks.
Highly doubt you can reset them. Do you have 12v to it with the key on or it is running. If you have voltage the meter is probably bad.
Maybe it disconnected..?
 

zachem

Forum Newbie
Joined
Jun 10, 2020
Threads
1
Messages
3
I dont necessarily care about reseting it. Just so it starts running again, so I can monitor personal use. Ill try a voltoneter to see if its working.

If it was disconnected, wouldnt the screen just be blank? It shows "7XX.X" on mine
 

zachem

Forum Newbie
Joined
Jun 10, 2020
Threads
1
Messages
3
I dont necessarily care about reseting it. Just so it starts running again, so I can monitor personal use. Yes it was running, I cut 2 lawns about. I had it running at least half hour, and it stayed the same.

If it was disconnected, wouldnt the screen just be blank? It shows "7XX.X" on mine
 

4getgto

Well-Known Member
Joined
Feb 4, 2017
Threads
1
Messages
179
I dont necessarily care about reseting it. Just so it starts running again, so I can monitor personal use. Ill try a voltoneter to see if its working.

If it was disconnected, wouldnt the screen just be blank? It shows "7XX.X" on mine
Yea it would be blank if it had no power. Thinking you're going to need a new hour meter. They do go bad . Not uncommon.
 
Top