throttle speed

Joined
Feb 26, 2020
Threads
10
Messages
38
Have 10515 it will not throttle down when moved to slow position. cable seems fine and is moving air vane new spring any ideas?
 

viperv10

Well-Known Member
Joined
Oct 7, 2016
Threads
38
Messages
136
I had the same thing happen to me. Found out that the end of the throttle spring came loose from the plastic cable linkage that slides back forth above your air cleaner box.
FuzzyDriver posted a link to a youtube video about this issue on my thread about no throttle response, just 2 threads down below yours. The video is a dura force but the throttles are set up just
the same as your F engine 10515. I don't know what else it could be. Let us know if you get it figured out.
Regards,
Jerry
 

Rivets

Lawn Royalty
Joined
Mar 11, 2012
Threads
47
Messages
11,526
If you installed a new governor spring under the air vane, it is set too tight and must be adjusted to lower idle RPMs.
 
Joined
Feb 26, 2020
Threads
10
Messages
38
i know by turning the nut it tightens or loosens but it runs fine at the high speed how do you cut the rpms?
 

Rivets

Lawn Royalty
Joined
Mar 11, 2012
Threads
47
Messages
11,526
I don’t know what nut you are talking about. Are you sure that the air vane is not hitting something, preventing it from closing the throttle? With the engine not running you should be about to move it very, very freely.
 
Joined
Feb 26, 2020
Threads
10
Messages
38
the serated black wheel is the nut i was refering too vane moves freely i might reinstall the spring and start from scratch
 
Top