Murray 46" rider. Model # 46107X92A

MowLife

Well-Known Member
Joined
Oct 18, 2018
Threads
3
Messages
365
Did you test the switch with harness unplugged from it?
 

platefire

Member
Joined
Jun 27, 2019
Threads
3
Messages
34
So you push down on the clutch to crank it up and when you put it in gear and let out on the clutch in any gear it dies? I have had a similar problem with our Church YT3000 Craftsman when I engage the mower deck dying. It does that intermittently. The way I overcome that is with the motor off engage & disengage the deck several times in a row then crank it up and try it. Sometimes I have to do it more that once and so far that's always got it going again until next time. So you might try pumping the clutch several times in a row to see if it makes a deference. I have even sprayed contact cleaner on the ignition switch and connectors with electrical problems. Most of the time rather than bad switches it's a connector or switch not making a connection because of corrosion or dirt. I always fiddle around with the electrical connectors usually UN-plugging them, spray on contact cleaner inside and plug them back together until I get good results. Never had to replace a switch yet. Bob
 

Scrubcadet10

Lawn Addict
Joined
Sep 24, 2017
Threads
99
Messages
1,480
installed a $10 Briggs & Stratton 7023354YP seat switch, fired it up moved in reverse and all 5 forward gears :thumbsup:
 

platefire

Member
Joined
Jun 27, 2019
Threads
3
Messages
34
Har! Right after I said that "I never had to replace a switch yet" that's exactly what you did to solve your problem:thumbsup:. I'm still working on my trouble shooting skills:ashamed:
 
Top