hustler mini z 36 inch deck belt won't stay on

John dude

Forum Newbie
Joined
May 19, 2021
Threads
1
Messages
4
hi everybody and thank you for reading my post. i have a hustler mini z 36 inch zero turn lawn mower the belt for the deck is always coming off of the tensioner pulley, i have talked to mechanics at hustler dealers and none of them seem to know what is wrong they are not hustler owners but I'm sure they know something about this nobody has been able to diagnose it i really hope that there is somebody who can help me on this please tell me if you have any info about this , but if you are having problems with your mower please tell me because i may know how to fix it i am a small engine mechanic and have done a lot and still can't figure it out so if if you have any info please share it thank you.
 

Born2Mow

Well-Known Member
Joined
Sep 18, 2020
Threads
9
Messages
689
The 34" Hustler Dash I owned did not incorporate a linkage from the deck to the frame. This meant that the deck was allowed to swing back and forth.... which is OK, but it plays havoc with the belt length and belt tensioner system.

Suggestions....
  • Make sure you are using the EXACT correct belt from Hustler, not some Chinese "almost fit" belt off Amazon. Often times the correct belt is (something like) 34.6 inches and the Amazon belt is a general fit-all 35.0 inches. Doesn't sound like much.... until the deck starts swinging.
  • Start with a new belt you know is the correct length.
  • Check the belt tensioner for movement and tension. Is the spring "sacked out" ? Is the tension arm roller OK ? Have you lubricated the tensioner arm lately, if ever ? Do the blade spindles require lubrication ?
  • Are all the belt guides in place ?
Hope this helps.
 
Last edited:

John dude

Forum Newbie
Joined
May 19, 2021
Threads
1
Messages
4
thanks man mine is like 10 yrs old and mine swings a lot so that is probably what the issue is along with the belt cuz I've just been getting some random belt from napa auto parts. thank you:)
 

Whitie365

Forum Newbie
Joined
Jun 30, 2021
Threads
0
Messages
1
I'm having the same issue I've replaced the tensioner, slides, tension spring, 3 of the 4 pullies, spindles and its still popping a new 116" belt.
 

Ron3

Active Member
Joined
Jun 5, 2021
Threads
2
Messages
84
thanks man mine is like 10 yrs old and mine swings a lot so that is probably what the issue is along with the belt cuz I've just been getting some random belt from napa auto parts. thank you:)
 
Top