Snapper mower with B&S 11.5hp won't start; Help!

WHR

Forum Newbie
Joined
May 20, 2020
Threads
1
Messages
5
Snapper mower with B&S 11.5hp won't start. Model #217802. It has a pull rope and has always been somewhat hard to start. It quit while mowing and haven't been able to get it going again. Have changed plug, checked spark, checked compression, taken carburetor apart, it is getting gas, am at a loss as to what else to try. It won't fire, even with ether. Any ideas?
 

keakar

Active Member
Joined
Apr 28, 2020
Threads
6
Messages
99
check for spark, the ignition coil most likely went out, they are like $8 on ebay for a new one

but if no spark then disconnect the black ground wire from the coil and see if it starts just to eliminate a safety switch issue such as you forgot to put on the brake before trying to start it
 

WHR

Forum Newbie
Joined
May 20, 2020
Threads
1
Messages
5
check for spark, the ignition coil most likely went out, they are like $8 on ebay for a new one

but if no spark then disconnect the black ground wire from the coil and see if it starts just to eliminate a safety switch issue such as you forgot to put on the brake before trying to start it
Already checked for spark; already disconnected ground wire. Still no fire.
 

Mkala

Well-Known Member
Joined
Jan 5, 2019
Threads
5
Messages
136
If you have spark, gas mixture and compression it would run. Except if you hit something and it stopped ?

If not, did you try to dump some fuel in the intake to see if it run a few seconds ?
 

WHR

Forum Newbie
Joined
May 20, 2020
Threads
1
Messages
5
We have checked the flywheel key, sanded the flywheel contacts, tried the coil on another Snapper and it started just fine. Still at a loss as to what else to do.
 

WHR

Forum Newbie
Joined
May 20, 2020
Threads
1
Messages
5
If you have spark, gas mixture and compression it would run. Except if you hit something and it stopped ?

If not, did you try to dump some fuel in the intake to see if it run a few seconds ?
Didn't hit anything when it stopped. The flywheel key is fine. I thought it was out of gas, but maybe not. It will not fire with gas or ether in the intake. See above as to what else we have tried.
 

WHR

Forum Newbie
Joined
May 20, 2020
Threads
1
Messages
5
Didn't hit anything when it stopped. The flywheel key is fine. I thought it was out of gas, but maybe not. It will not fire with gas or ether in the intake. See above as to what else we have tried.
What should the compression be? Someone told us 100. Another site said 80 to 100. It showed 80.
 

Mkala

Well-Known Member
Joined
Jan 5, 2019
Threads
5
Messages
136
Didn't hit anything when it stopped. The flywheel key is fine. I thought it was out of gas, but maybe not. It will not fire with gas or ether in the intake. See above as to what else we have tried.
Ok if the timing is right and the spark is good, I don't understand why it does not fire if you put some fuel in the intake.

80 PSI is low I think for a not that old OHV engine, but someone more knowledgeable than me should help you for this case !
 
Top