Kohler Command Pro 23 Smoking

Hayward51

Member
Joined
Mar 25, 2022
Threads
2
Messages
21
I bought this '02 Scag for parts then, unfortunately, decided to restore it. It had a replacement engine (CV23) on it with breather separator missing from valve cover. Being it was sitting out in the weather, PO stated it was full of water. I tore down the engine and surprised there was no obvious damage in the crankcase or cylinders. I took measurements and cleaned up and decided to rebuild. I reused all but rings and gaskets. After rebuilding rusty carburetor, I cranked it up and was thrilled with the rebuild job. I noticed smoke when it started and accelerated so I think I should replace the old valve stem seals. I pulled the heads and replaced seals and head gaskets along with lapping valves again. I torqued everything back down and now it smokes constantly. ?? I have no load on the engine yet and ran at various RPMs for maybe 30 mins to seat rings. I know this is already long but, one other thing. I noticed it started running on one cylinder (before I pulled the heads) and discovered a new ignition coil was bad. I thought maybe the dead cylinder was letting fuel in and was blowing by the rings. I changed the oil and it didn't help the smoking. Any suggestions ? I would also like to add - I did a compression test and got very high readings = #1 - 190 #2 - 170
 
Last edited:

Hayward51

Member
Joined
Mar 25, 2022
Threads
2
Messages
21
Thanks, I have a manual and rebuilt engine as close as possible to the specs. While I was lapping valves, I noticed slight warp in head. I placed sandpaper on glass plate and took some of the warping out. Could that warp or pitting in valve seat be my culprit ?
 

hlw49

Well-Known Member
Joined
Jul 11, 2021
Threads
19
Messages
915
Warp could cause it if the head gasket does not seal. Could be a broken crankcase reed valve. One for each cylinder in the push rod area.
 

Hayward51

Member
Joined
Mar 25, 2022
Threads
2
Messages
21
Thanks, hlw49, that's something (reeds) I wasn't aware of.
 

Hayward51

Member
Joined
Mar 25, 2022
Threads
2
Messages
21
Warp could cause it if the head gasket does not seal. Could be a broken crankcase reed valve. One for each cylinder in the push rod area.
I don't find a crankcase reed valve other than in the breather.
 
Top