john deere 316 onan p218g not charging any ideas

xpackdals

Forum Newbie
Joined
Jan 7, 2013
Threads
2
Messages
8
The bat light is staying on so i tested the 2 wires from stator where they hook to the rectifier and im showing 30-32 vac then i hooked them back up to the rectifier and pull the center wire off the rectifier and at the rectifier im showing 13.20 vdc but as soon as i hook the wire back to the rectifier it drops to 12. vdc. I just got this tractor it belonged to my dad whos no longer here and since he has been gone it hasnt been kept up with so now that i have it im bringing it back up to its original state which will include a complete restore after i have fixed every thing thats wrong with it. I dont currently have any books for it but there coming so i dont have a wiring schematic but doing some net research i am seeing that there is a time delay control module on this tractor which is a 1990 and i removed it hoping to see something bad on the board but it looks to be in great shape and i have read that it controls the charging on this tractor but i dont know for sure if it does or not. I have checked all the wire connections and they look to be good and clean this is also a new battery and it runs and operates like it should it just is not charging any help would be great
 

reynoldston

Lawn Pro
Joined
May 23, 2011
Threads
91
Messages
5,691
I have seen where John Deere installs a fuse to the voltage regulator you might want to check for this.
 

EngineMan

Lawn Addict
Joined
Jun 12, 2012
Threads
9
Messages
2,275
Going by the wiring diagram that I look at there is a 2Amp fuse in line with the discharge light control, it seems to be near the key switch, other then that replace the regulator.
 

xpackdals

Forum Newbie
Joined
Jan 7, 2013
Threads
2
Messages
8
I looked for fuses in the lines and by the ignition and found none the only 2 i see are a 20 amp and a 3 amp push in type and they both check out good and im not sure what they are for.I dont understand why the voltage drops when i hook up the wire to the center of rectifier before the wire is hooked i get 13 plus vdc
 

bouty

Forum Newbie
Joined
Jan 12, 2014
Threads
0
Messages
1
The bat light is staying on so i tested the 2 wires from stator where they hook to the rectifier and im showing 30-32 vac then i hooked them back up to the rectifier and pull the center wire off the rectifier and at the rectifier im showing 13.20 vdc but as soon as i hook the wire back to the rectifier it drops to 12. vdc. I just got this tractor it belonged to my dad whos no longer here and since he has been gone it hasnt been kept up with so now that i have it im bringing it back up to its original state which will include a complete restore after i have fixed every thing thats wrong with it. I dont currently have any books for it but there coming so i dont have a wiring schematic but doing some net research i am seeing that there is a time delay control module on this tractor which is a 1990 and i removed it hoping to see something bad on the board but it looks to be in great shape and i have read that it controls the charging on this tractor but i dont know for sure if it does or not. I have checked all the wire connections and they look to be good and clean this is also a new battery and it runs and operates like it should it just is not charging any help would be great

I dont know if you still need help but i had the exact same problem and i even put a new stator and everything in, it turns out the fly wheel it had in it was the wrong fly wheel i dont know if yours will be the same. It had a green flywheel in it and we happened to score a free stock flywheel that came off a family members tractor and that was black, i swapped them and now she runs good as new
 
Top