Homelite string trimmmer runs on the first or second pull - but only for 1 or 2 seconds.

Hmobley50

Forum Newbie
Joined
Jun 20, 2021
Threads
2
Messages
8
My Homelite engine information shows: EM PS-01525, engine family XH2XS.0254RA. Runs for probably 1 second. That is with full or 1/2 choke after sitting for some hours. All subsequent pulls a futile. Choke, no choke, full throttle, various combinations. Hours later I can set the choke and one or two pulls and it runs for a second.
Most recently I replaced the fuel tank and lines because the line into the tank completely failed. When I prime the carb I get circulation from the tank but the bulb ends up almost 1/2 full of bubbles. That seems wrong. Thanks in advance for the help.
 
Last edited:

Hmobley50

Forum Newbie
Joined
Jun 20, 2021
Threads
2
Messages
8
I'm not finding a manual for the em ps 01525 trimmer. Lots of near misses, it seems. I'd love to find a troubleshooting section.
It quit and i put any kind of small hose into the fuel tank. It ran for a while but quit at about 1/2 a tank. Then it wouldn't start and I wound up buying and installing a new tank with proper lines and a filter. Now, on the first or second pull with choke on, it just fires a few times and quits. Massive cranking with and without choking, with and without throttle at full, yields nothing but a sore arm. A few hours later, same scenario, choke, pull, sputter. Thanks in advance for your help.
 

mechanic mark

Lawn Pro
Joined
Jul 15, 2013
Threads
161
Messages
6,260
Just a suggestion July 4th is coming soon & if you are an Honorably Discharged Veteran & have a Veteran Card for ID you may get 10% off. I have 2 Echo Model 210 trimmers, always use Echo 2 cycle oil with 93 octane gasoline with Star Tron Fuel Treatment added to gas can per instructions on bottle. Trimmers are at least 15 to 24 years old. Just purchase tune up kit every 2 or 3 years & perform preventive maintenance.
 
Top