Deck issues

JB2020

Forum Newbie
Joined
Mar 22, 2020
Threads
2
Messages
3
Im new to this site. I have a John Deere LT155 that has issue with blades grinding when they're engaged. I would like to fix the problem myself without going to repair shop. Any advice on how to determine what's bent and best way to fix it.
 

bertsmobile1

Lawn Royalty
Top Poster Of Month
Joined
Nov 29, 2014
Threads
28
Messages
13,506
remove the deck belt the spin the blades by hand.
They should spin easily and quietly
grad the blade and try to push pull it, there should be no movement up & down.
Grab the ends on the blades and try to rock them in a see saw motion , again should be no movement.

Any failure means the bearings have gone.
Remove the pulley on top while holding the blades
THe blade & spindle should tap out towards the bottom as a unit

GEt good bearings from a mower shop or specialist bearing supplier , not cheap ones of Amazon ebay etc unless you feel like becoming very proficient at replacing spindle bearings.
On very rare occasions the actual housing can break near one of the mounting bolts .

If the blades have been hitting each other then that will need cleaning up with a file / grinder then you may as well sharpen the blades and balance them.
If not balanced again the bearings will wear out very quickly.
 

StarTech

Well-Known Member
Joined
Feb 19, 2020
Threads
1
Messages
548
Please view the double post where he may have the 42" deck.
 

Catherine

LawnWorld Support
Joined
Jun 13, 2015
Threads
2
Messages
1,495
Welcome to the forum :)
Hopefully, one of the answers you get will be the right one.
 
Top