craftsman riding lawn mower model 917.275013 with a Kohler engine

Thom75

Member
Joined
Oct 14, 2022
Threads
5
Messages
17
  • / craftsman riding lawn mower model 917.275013 with a Kohler engine
craftsman riding lawn mower model 917.275013

Kohler engine

Battery not being charged
The stator is producing 40 volts A/C, BUT zero volts D/C

Also, when I push down the clutch pedal to start the engine, the engine runs, but quits when

I release the clutch pedal.

Also, I discovered that with the clutch pedal down, and the engine running,

when the PTO is engaged, the engine will quit. I disconnected the PTO clutch connector

but the engine still quits when the PTO is engaged.

I wonder if replacing the voltage regulator will solve the issue with engine quitting?
 

StarTech

Lawn Pro
Joined
Feb 19, 2020
Threads
44
Messages
6,991
  • / craftsman riding lawn mower model 917.275013 with a Kohler engine
It probably a bad voltage regulator on the charging issue.

On the engine with the clutch/brake up or when the clutch.brake down and the PTO engaged it is either a bad seat switch or the operator present relay.
1666814316433.png
 

Thom75

Member
Joined
Oct 14, 2022
Threads
5
Messages
17
  • / craftsman riding lawn mower model 917.275013 with a Kohler engine
Jumping the seat switch did not solve the problem.
 

StarTech

Lawn Pro
Joined
Feb 19, 2020
Threads
44
Messages
6,991
  • / craftsman riding lawn mower model 917.275013 with a Kohler engine
Does the electric PTO even tries to engage with the ignition in run and someone on the seat? IF not then pull the Operator present relay then see if the mower will stay running.
 

Thom75

Member
Joined
Oct 14, 2022
Threads
5
Messages
17
  • / craftsman riding lawn mower model 917.275013 with a Kohler engine
With the relay disconnected, the engine will continue to run when I pull up on the PTO,but the blades will not even try to spin.
Also, with the replay disconnected,I have 5 volts on the green wire to the relay.I have 5 volts on the red wire to the clutch
with the wire connected to the clutch.
 

StarTech

Lawn Pro
Joined
Feb 19, 2020
Threads
44
Messages
6,991
  • / craftsman riding lawn mower model 917.275013 with a Kohler engine
Okay there should have the battery voltage or higher on both the red and green wires. Check the A1 terminal on the ignition switch for battery voltage with the engine not running but the ignition switch in the run position. Also make the terminals at the ignition switch are good as they are F56 terminals and the spring contacts can break causing loose connections.

Also sound the PTO clutch was trying to engage prior to relay being removed so that should indicate the relay is okay.

The relay was superseded from 109748X to 532109748.
1666902224654.png
 

Thom75

Member
Joined
Oct 14, 2022
Threads
5
Messages
17
  • / craftsman riding lawn mower model 917.275013 with a Kohler engine
Okay there should have the battery voltage or higher on both the red and green wires. Check the A1 terminal on the ignition switch for battery voltage with the engine not running but the ignition switch in the run position. Also make the terminals at the ignition switch are good as they are F56 terminals and the spring contacts can break causing loose connections.

Also sound the PTO clutch was trying to engage prior to relay being removed so that should indicate the relay is okay.

The relay was superseded from 109748X to 532109748.
View attachment 62661
the A1 terminal has now voltage on it with the KOEO.
 

Thom75

Member
Joined
Oct 14, 2022
Threads
5
Messages
17
  • / craftsman riding lawn mower model 917.275013 with a Kohler engine
Well, thanks to all who responded to my post.
I replaced the ignition switch, and all is right as rain.
 

slomo

Lawn Addict
Joined
Jul 14, 2019
Threads
71
Messages
3,743
  • / craftsman riding lawn mower model 917.275013 with a Kohler engine
I would of checked the G terminal for a clean solid ground. Too late now as it's running.
 
Top