2006 Bronco 18.5hp running poorly

Joined
Jul 7, 2019
Threads
9
Messages
22
I am working on a 06 Bronco with an 18.5hp Briggs and Stratton Intek Single Cylinder, it runs pretty well at idle and when easily giving it throttle but if I give it throttle too fast it starts surging, backfiring through the carb and sometimes will recover if I throttle it down or will die. When it dies it will crank and backfire loud out the exhaust once then nothing, pull the plug and it's wet. It will also die like I explained above when engaging the blades. It had a bad compression release and I installed a new camshaft, any ideas. It was surging badly with the old carburetor so I installed an amazon carb on it, that fixed the surging but it still isn't right.
 
Joined
Jul 7, 2019
Threads
9
Messages
22
I went back out and burned the sparkplug clean with my propane bottle torch and reinstalled it, it seems to be running good now its reactive to throttle changes and I can engage the blades. It does seem like its burning some oil, it arrived to the shop non running so I am just getting to see what it's like now but a couple minuets running in the shop and it smells like burning oil and I get a puff of blue smoke out the exhaust when I throttle up.
 

slomo

Lawn Addict
Joined
Jul 14, 2019
Threads
66
Messages
2,568
Might be early head gasket leaking or dead piston rings. Does the oil smell like fuel? Smell the dipstick.

Clean the OEM carb. Might take a couple cleanings to run proper. Get anal on your cleaning ritual. Think hospital clean.
Mr-Clean-Logo-600x600.jpg


slomo
 

slomo

Lawn Addict
Joined
Jul 14, 2019
Threads
66
Messages
2,568
You fixed it "temporarily" with the propane torch. Oil will eventually foul the plug again. Fix the oil issue or the customer will be back. Put the OEM carb back on.

slomo
 
Top